トップ 差分 一覧 ソース 置換 検索 ヘルプ PDF RSS ログイン

Debian 系で CG-WLUSB300GNM を使う

http://www.linuxcrew.de/blog/2010/10/11/rt2870-compile-error-under-kubuntu-maverick-10-10/?lang=en
http://kzen.my-sv.net/wiki/index.php?Linux%2FWLUSB300GNM
https://forums.ubuntulinux.jp/viewtopic.php?id=10742
http://u220e.blog59.fc2.com/?m&no=1

Ralink社からRT2870のドライバソースを持ってくる。

2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2(394)

tar xvf 2010_0709_RT2870_Linux_STA_v2.4.0.1.tar.bz2

パッチをあてる

rt2870sta_usb_kernel2635.patch(350)

patch -p0 -l < rt2870sta_usb_kernel2635.patch

ソースを修正する

HAS_WPA_SUPPLICANT=n
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n

の2つを

HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

$ lsusb
Bus 001 Device 005: ID 07aa:0042 Corega K.K.

この中で、"Corega K.K."というのがWLUSB300GNMなので、このID:07aa:0042をメモる。
$ vi ./common/rtusb_dev_id.c

USB_DEVICE_ID rtusb_dev_id[] = {
#ifdef RT2870
       {USB_DEVICE(0x07AA,0x0042)}, /* Corega K.K. */
         (以下略)

コンパイルとインストール

make
make install

モジュール読み込み

modprobe rt2870sta

[カテゴリ: OS > Linux]



  • Hatenaブックマークに追加
  • livedoorクリップに追加
  • del.icio.usに追加
  • FC2ブックマークに追加

最終更新時間:2011年10月19日 23時17分14秒