トップ 差分 一覧 ソース 置換 検索 ヘルプ PDF RSS ログイン

postgresqlのエラー


古いバージョンのデータベースフォーマットが見付かりました

http://snowland.net/nucleus/item/2423

古いバージョンのデータベースフォーマットが見付かりました。
PostgreSQL を使う前にデータのフォーマットをアップグレードする必要があります。
より詳細な情報は /usr/share/doc/postgresql-8.3.7/README.rpm-dist を見てください

っと表示される場合は、Postgresqlのバージョンが変わったときに起こると思われるので

  • /var/lib/pgsql/data をリネームして削除扱いにする
  • service postgresql initdb してdataを新規に作る
  • service postgresql start
  • pg_dumpallしてたデータをリストアする
  • pg_hba.confとかpostgresql.confの内容を見直して再起動

[カテゴリ: データベース > Postgresql]



  • Hatenaブックマークに追加
  • livedoorクリップに追加
  • del.icio.usに追加
  • FC2ブックマークに追加

最終更新時間:2010年09月08日 23時59分25秒